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Chapter 1  - Introduction 

This chapter gives you a basic description of 

Micrographica concept and purposes. 
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Welcome to Micrographica... 

Micrographica„s Scientific Imaging Software suite is intended for acquisition, 

measurement and analysis of digital media - images or movies - in microscopy 

and machine vision. The aim of the software is to provide you with fully 

featured, powerful but easy to use imaging software. 

 

With Micrographica Standard Edition you can: 

 Control, preview and capture images from a wide range of input devices 

such as still picture cameras, video cameras and frame grabbers. 

 Combine several images of the same scene made with different focus depth 

into one image with extended depth of focus (EDF). 

 Combine series of partial images from the same scene (tiles) into one big 

image. 

 Easily make rich annotations and measurements on the captured image. 

 Process and enhance the picture by applying filters and tools. 

 Customise and generate reports. 

 Control motorized microscope accessories and perform automated scans 

(optional module). 

 

In addition, with Micrographica Video Edition you can also: 

 Record video sequences. 

 Apply animated annotations and measurements. 

 Dynamically process and enhance the entire video sequence. 

 Automatically track features within the video sequence. 

 

Micrographica will continue to develop and offer new additional plug-ins, which 

means you can easily upgrade your software in future to include new 

functionality. Please note that some of these plug-ins may require you to 

purchase an additional license. Please check with your distributor or our 

website for details. 
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Each chapter of this user manual contains three sections: 

In brief… 

Gives you a quick overview of the basic features and commands 

In detail… 

Gives you a more detailed description including options and background 

information. 

Tips… 

Gives you additional tips, short-cuts etc. 
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Chapter 2  - Installation 

This chapter describes how you install and register 

your version of Micrographica. 
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In brief... 

 Start the installation package named Micrographica_setup.exe and follow 

the instructions on screen. 

 After successful installation start the Micrographica software from the 

Windows Start Menu or from the shortcut on your Windows Desktop. 

 When the registration dialog appears, fill in the required fields with initial 

data i.e. names and the licence number (provided to you by the distributor 

from where you bought the software). The software will now run in demo 

mode. 

 Click the <Generate ID> button and note down the number displayed in the 

[Program ID] field. 

 Go to Micrographica‟s website www.micrographica.com/buy&download.htm 

and follow the instructions. 

 Once you have received the Registration Key from Micrographica enter this 

into the [Registration key] field and press <OK>. 

 The software is now fully licensed, registered and will run without any 

limitations. 

 Registration dialogue box 

 

http://www.micrographica.com/buy&download.htm
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In detail... 

Installation 

During installation the installer allows you to select the required software 

components. Some of these components are compulsory, some are optional. 

Application executables and Required System Libraries should always be 

selected during the first installation. However, during an upgrade or 

updating/repair installation these might not be required. 

The section Program extensions lists components, which are optional. These 

are plug-ins, which add certain program features, which may not be required 

by certain users. Installing features, which are not going to be used can reduce 

available memory and other system resources during runtime and decrease the 

performance. Some plug-ins may require you to purchase additional licences. 

Always make sure that you install only those plug-ins, which are part of the 

purchased product. 

The section Camera Drivers list available camera drivers. Select only those 

needed for supporting your camera model(s). As with plug-ins, installing 

drivers, which are not be used can reduce available memory and other system 

resources during runtime and decrease the performance. 

Registration 

In order to use the program in full mode a registration process is required.  

After starting an unregistered copy, the program displays the registration 

dialog. Fill in User data section i.e. Company name, User name and Licence 

number fields. The licence number is provided by a reseller. 

When a valid licence number is entered, the <Generate ID> button becomes 

enabled. Click the button and write down a code displayed in the [Program ID] 

field. Go to Micrographica‟s website  

www.micrographica.com/buy&download.htm and follow the instructions. 

In reply Micrographica support will send the registration key code, which should 

be entered in [Registration key] field. Clicking the <OK> button finishes the 

registration. If you want to start the program without waiting for the 

registration key, you can leave the [Registration key] field empty. The 

program will then run in „demonstration mode‟ and some features will be 

disabled or unavailable. The program will ask for a registration key at every 

start until the key has been entered. The program will then run in „full‟ mode. 

Note, that some plug-ins, drivers or extensions will require a special licence. 

Without providing a proper licence number some features may not be available 

even if a required extension was installed. 

http://www.micrographica.com/buy&download.htm
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System Requirements... 

 

Minimal hardware: 

Intel Pentium 4 or AMD Athlon compatible processor 1GHz 

512 MB RAM 

Direct X 9.0 compatible graphics 

1024x768 resolution, full colour display 

USB 2.0 compatible ports 

 

Recommended hardware: 

Intel multi-core processor 1.5 GHz or higher 

2GB RAM 

Direct X 10.0 compatible hardware accelerated graphics 

1280x1024 resolution, full colour display 

USB 2.0 compatible ports 

IEEE-1394 (Firewire) ports 

 

Software: 

MS Windows XP SP3, Windows Vista or Windows 7 (32/64 bit) 

Direct X 9.0 or higher 
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Chapter 3  - User Interface 

This chapter describes the basic elements of the 

user interface and how to use them. 
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In brief... 

 Use menu View->Windows to show/hide elements of the user interface such 

as dialogs, docking windows, toolbars. 

 

 Use menu Tools to open dialog and windows to perform additional tasks. 

 

 Use the <Undo/Redo> buttons or menu Edit->Undo/Redo to undo or redo 

recent actions. 

 Use menu Help->Help… to open this manual in a separate window within the 

program. 
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 Use menu Help->What’s this? to display a short description about an item 

pointed at by the mouse cursor. 

 

In detail... 

Micrographica uses the common Microsoft Windows user interface familiar to 

most users. There are windows, docking windows, dialogs and toolbars. Typical 

elements of the application window are shown below. 

 

Micrographica uses the concept of „docking windows‟. A docking window is a 

standard window which can be „stuck‟ (docked) to one of the sides of the main 

(application) window. Some docking windows can be docked on the left or the 

right side of the main window, while others can be docked on the top or at the 

bottom of the main window. When a window is docked it effectively decreases 

the available area of the main window, including the workspace. 

 

 Toolbars Docking window 

(undocked) 

Docking windows 

(docked) 

Dialog or 

window 
Workspace 

Status bar 
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To reduce complexity and the number of menus most of the functionality is 

available from the docking windows, which can be shown or hidden depending 

on your needs and required tasks. A list of docking windows is available under 

menu View->Windows, where individual windows can be switched on or off. 

The workspace is the main working area of the application window, where the 

current picture or the actual frame of the current video is displayed. There is 

only one workspace and therefore you can work with only one image or one set 

of video material at the time. 

Tips… 

The workspace is combined with a set of tool buttons located on the right side 

of the workspace. Four of them control the visible size of the current image:  

The <+> and <-> buttons increase or decrease the visible size of the current 

image by the factor of 2. The same is possible by using the <+> and <-> keys on 

the keyboard. 

 The <1:1> button restores the original visible size of the current image. The 

same is possible with the </> key on the keyboard.  

The <fit> button adapts the visible size of the current image to the actual 

workspace size. The same is possible with the key <0> on the keyboard.  

Use the mouse wheel to smoothly adjust the visible size of the current image. 

Use the left mouse button with ctrl + space keys to move (pan) the visible view 

of the current image across the workspace. 
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Chapter 4  - Still Image 

Acquisition 

This chapter describes how to work with digital 

still and video cameras in order to acquire a 

new image into the program. 
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In brief... 

 Use menu View->Windows->Camera Control to show the camera control 

window if this is not yet visible. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Select an active camera device from the [Select Device] list. 

 

Still camera control window 

 

 Video camera control window 
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 Manipulate camera settings using controls in the camera control window. 

 Click the <play> icon if the current camera is a video device. 

 Observe live view (if available) from the camera on the control window or on 

the workspace (depends on camera type and current Preview mode). 

 Click the <camera> icon (in case of still device) or <record> icon (in case of 

video device) to capture and display a new image. 

In detail... 

Micrographica can work with a wide selection of still and video cameras. The 

program uses its own controllers (drivers) to talk with a camera. Typically, 

cameras from different manufactures need separate controllers (e.g. Canon 

digital cameras need different controller than Olympus cameras). Sometimes, 

even some camera models from the same manufacturer need separate 

controllers (e.g. a  Canon EOS camera needs a different controller than a Canon 

G7 camera). On the other hand, some cameras from different manufacturers 

are supported by a single controller in Micrographica. This is the case with 

some USB or Firewire (IEEE 1394) video cameras and video grabber cards, which 

can be controlled by a common WDM (Windows Driver Model) controller. 

In order to work with a specific camera model the appropriate controller(s) 

should be selected during program installation. It is recommended not to install 

more controllers than required, as all installed controllers are loaded during 

program start up and remain in the memory even if not used and hereby 

wasting computer resources. 

During program start up each installed controller tries to recognize all the 

connected devices it can handle. When the program is ready, the [Select 

device] list in the Camera Control window contains all the camera devices, 

which exist in the system and which are recognized by any controller. Every 

item on the list consists of a camera device name, followed by the „parent‟ 

controller‟s name. 

Sometimes a camera can be recognized by more than one controller, and as a 

result the same device is reported twice on the list. This often happens when a 

WDM device is recognized by the common WDM controller and also by the 

device‟s custom controller. You should always select the custom controller over 

the common one. For example, Nikon DS-U2 cameras are recognized by a 

special DS-U2/L2 controller and by the WDM controller as well, but the WDM 

driver does not give full control over the camera. The device reported by the 

DS-U2/L2 controller should be selected. 

Note, that even the proper controller may not in all cases be enough for 

Micrographica to recognize and use the connected device. Many camera devices 

need an additional system driver. Such device should be installed in the system 

by using the special installer of the camera manufacturer before it can be 

recognized by a controller and used with Micrographica. 



 

 

 

   

User Manual Micrographica Standard & Video Edition v 1.7.0 Page 17 

Working with digital still cameras 

Digital still (photo) cameras typically do not need any special system drivers. If 

a proper controller is installed an USB connected camera should be visible on 

the list. Once selected, the camera gets activated and control fields of the 

camera control window are populated with data. The camera icon changes 

from „closed‟ to „open‟ state and if live view from the camera is supported, it 

becomes visible in the preview area of the window. 

Micrographica can control a number of the camera‟s features including image 

resolution/quality mode, camera flash, focus and ISO modes. The lenses zoom 

can be adjusted. The battery charge level is indicated with a green bar above 

the preview area. 

Normally, a live view displayed in the preview area is delivered from the 

camera by the USB link. However, some photo camera models do not support 

USB live view. In that case, a preview from the camera can still be visible using 

the camera‟s video output connector. In order to use it, the computer should 

have a video input device installed. Such device can be a VIO card, frame 

grabber card or USB video input adapter. The video output from the camera is 

then connected to the video input device and the [Video out] box on the 

window should be selected. To see the live view on the camera‟s LCD screen 

instead of preview on the computer select the [LCD] box. 

 

Note that not every camera model may support all features and some controls 

will be disabled or empty. For example, SLR cameras like Canon EOS typically 

do not support remote zoom or auto focus mode. Also, some values for modes, 

which can be set manually on the camera, cannot be set remotely via the USB 

connection. 

When the camera is active, a remote release (snapshot) can be made by 

clicking on the <Camera> icon. When the image is ready, it is instantly 

downloaded to the application and displayed in the workspace as the new and 

current image. The download progress is indicated by the status bar of the 

application window. The image is not stored on the camera‟s internal memory 

or card, unless [Store image in camera] box is checked. 

Working with video devices 

If a connected video device (camera or video input card/adapter) is set-up in 

the system and the right controller is installed with Micrographica, the device 

will be visible on the list. Selecting the device from the list activates it, but the 

preview is not yet visible. Clicking the <Play> button starts the live preview, 
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which now is visible in the workspace. Live preview can be paused by clicking 

the <Pause> button. 

A still image snapshot is done by clicking the <Record> button. The preview 

from the camera is stopped and the snapshot image from the device is instantly 

downloaded to the application and displayed in the workspace, replacing the 

live view. 

The resolution of the snapshot can be selected with the still image 

[Resolution] list. Usually, changing the resolution also changes live preview 

resolution (size), but on some devices snapshot and video resolutions are 

independent. 

The <Set input...> button displays a dialog, where some properties of video 

input can be set. This applies mainly to frame grabbers or video adapters and 

most camera devices do not support input settings. 

The <Set filter...> button opens a dialog, where some image processing 

properties can be set - brightness, contrast, colour balance etc. When the 

dialog is open, live preview is still active. The dialog is delivered by the device 

controller or device driver and therefore can contain different sets of controls 

depending on the device. 

The <Set output box...> button opens a dialog, where video output properties 

of the device can be set - video resolution, video mode, binning etc. When the 

dialog is open, live preview is paused. The dialog is delivered by the device 

controller or device driver and therefore it can contain different sets of 

controls depending on the device. 

Tips... 

Connected devices are recognized and added to the list during program start 

up. If a device connects or disconnects during the program runtime, the device 

list is not updated. By clicking the <Refresh> button, you can force the 

program to update and reload the connected device list. If any device is active 

during the refresh, it is stopped and deactivated before the update. After the 

process no device will be active. Select the required device again in order to 

activate it.  
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Chapter 5  - Calibration 

This chapter describes how to calibrate the 

workspace and to manipulate calibration sets. 
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In brief... 

 Calibration sets are controlled via the calibration toolbar. If the toolbar is 

not visible, switch it on using menu View->Windows->Calibration Tools. 

 Use the <Create new calibration> icon on the toolbar to create a new 

calibration set. The new calibration name will be displayed as the current 

one on a list left to the icon. 

 Use the <Calibrate> icon to go to the calibration mode. Calibrate by drawing 

a line on the workspace. Select unit and value in a displayed dialog. 

 Use the <Rename Calibration> icon to rename the current calibration set. 

 Use the calibration list to select among existing calibration sets. 

 Use the Grid, Sight and Scale boxes to display calibration elements in the 

workspace.  

 

 Use <Delete Calibration> icon to remove the current calibration set. 

In detail... 

The calibration process is crucial when reliable measurement and image 

analysis results are expected. To calibrate you should use the special 

calibration target provided by most microscope or camera suppliers. 
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The target should be placed close to the centre of the image area and should 

be clearly and sharply visible in the live preview. Calibration can be done on 

the live preview, but it is recommended to do it on the captured image 

(snapshot) or recorded video. 

Click the <Calibrate> button on the calibration toolbar to start the calibration 

mode. Use the mouse cursor to draw a line from one mark of the calibration 

target to another mark. To get the most accuracy the line should be as long as 

possible and parallel to the target. When the calibration dialog appears enter 

the distance value between the marks on 

the target expressed in target‟s units 

(usually micrometers). The unit should be 

selected in the dialog as well. This way you 

can create calibration sets for every 

combination of image resolution and 

microscope‟s objective. 

With the calibration bar you can use three typical calibration objects – scale, 

grid and sight (cross). The scale (if switched on) is visible only when any 

calibration is active. The size of the scale and the number of units is adjusted 

automatically according to the current size of the view. The scale can be 

moved on the image area by using the pointer tool - just as any animation or 

measurement objects. 

The grid (if switched on) is formed by horizontal and vertical dashed lines. By 

default the grid lines are drawn for every unit of the current calibration (x1). 

By clicking with the right-mouse button on the workspace you can select other 

densities – x5, x10 or x100, which means grid lines are drawn for every 5, 10 or 

100 units respectively. If the grid is too dense to display (e.g. when the image 

view is too small) the grid lines are not displayed and you should select lesser 

density of the grid. The grid can be moved on the image area by using the 

pointer tool. 

Tips... 

When calibration is performed on an image captured with a still image (photo) 

camera, the camera' zoom is taken into account automatically. This means that 

the calibration made on any image taken with one zoom can be used on any 

image taken with a different zoom value, providing image resolutions and 

microscope objectives are identical. However, reliability of this feature is 

limited, because the zoom value may not be reported precisely by some 

compact cameras. In that case, measurement results on images with various 

zooms can be different. You are recommended to always test this with your 

own camera. 
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Chapter 6  - Annotations and 

measurements on still images 

This chapter describes how to use annotation 

and measurement objects on still images. 
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In brief... 

 Annotation and measurement objects can be created via the annotation 

toolbar. If the toolbar is not visible, switch it on using menu View-> 

Windows->Image Tools. 

 

 

 Select the desired tool from the toolbar. 

 Draw an object on the workspace by dragging the mouse. 

 Set the object properties by clicking on the object with the right-mouse 

button. 
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In detail... 

Micrographica offers a concept of universal measurement/annotation objects. 

This means that almost any graphical object created on an image can be used 

to annotate (emphasis) and measure image features. Such objects can display 

measurement values and hereby also act as measurement objects. When you 

switch the displayed value off (by the context menu), the object only marks a 

feature on the image, acting as the annotation. To create and manipulate 

objects, several tools are provided on the Annotation tools toolbar. 

 

 

Tools from left to right: Pointer, zoom, mask, view, angle, pen, pencil, ellipse, rectangle, 
auto trace, dimension (distance), counter, arrow, label. 

 

Pointer tool  

The pointer tool is a standard tool to select and manipulate objects on the 

workspace. Click on any object with the tool to select the object and make it 

the current one. Selected objects are indicated by its bolder shape. The 

current object (only one at a time) is usually decorated with some manipulation 

elements depending on type of the object. The current object is always a 

selected one, so it has a bolder shape as well. By marking a rectangle area on 

the workspace by the pointer tool, you can select a group of objects, creating a 

„multi-selection‟. Clicking on an object, which is not yet selected, with the 

<Shift> key pressed, adds the object to a multi-selection. Clicking already 

selected object with the <Shift> key pressed, removes the object from a multi-

selection. Double click with the tool on some objects can perform special 

actions like properties dialog display or view activation. Right-mouse click on 

an object opens a context menu, which contains several possible actions for the 

object - like colour change, delete, hide etc. 

Zoom tool   

The zoom tool is used to magnify or minify the current image view in the 

workspace. Clicking with the tool in the workspace enlarges (zoom-in) the view 

by the factor of 2. With the <Alt> key pressed the view is shrunk (zoom-out) by 

the same factor. Dragging the tool (with or without the <Alt> key) on the 

workspace marks the area for zooming and allows you to magnify or minify the 

view more precisely. 
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Mask and View tool   

See Chapter 9  -for details. 

Angle tool   

The angle tool is used to draw angle objects on an image. By pressing the left 

mouse button with the tool selected, the angle object is created with one arm 

horizontally fixed. The second arm of the angle can be adjusted by dragging 

the mouse. Releasing the mouse button finalizes creation of the angle. The 

angle object can display only one measured value type – the angle (in degree 

units). 

 

Pen tool (Bezier mode paths and contours)   

The pen tool is used to create Bezier poly lines, paths, polygons or curve-

shaped regions on an image. The shape of the object is determined by nodes 

and handles – typical elements of Bezier curves. By pressing the left mouse 

button you create the next node. Dragging the mouse with the left button still 

pressed adjusts the symmetrical handles. Releasing the button finishes the 

current curve segment and you can add the next node. When a node is created 

with a left button mouse click only (without dragging) handles are not set and a 

poly line can be created instead of a curved path. 

The path or the poly line can be closed (forming a contour or a polygon) when 

the last node of the path is placed on the first node.  

The object can be edited at any time by moving its nodes and handles with the 

pointer tool. Handles behave as unsymmetrical, but every pair is aligned. To 

move handles individually (unaligned) use the pointer tool with the <Alt> key 

pressed. Unaligned handle pair can be put back into aligned and symmetrical 

mode by using the pointer tool on the node with the <Ctrl+Alt> keys pressed. 
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Individual and multiple nodes on the current object can be selected with the 

pointer tool. The selected nodes can be removed with the <Del> key. 

The pen created path/region object can display several measurement values: 

horizontal width, vertical height, length (path only), perimeter (region only) 

and area (region only). 

 

Pencil tool (freehand paths and contours)   

The pencil tool is used to create freehand poly lines, paths, polygons or curve-

shaped regions on an image. The object is formed by the series of nodes 

connected with straight lines. By clicking on the workspace with the tool, you 

can create poly lines. By dragging the mouse you can create „freehand‟ curved 

shapes. A shape can be closed „manually‟ (when the new node is placed on the 

first node), or at any time by clicking with the right-mouse button. 

The object can be edited the same way as any object created with the pen 

tool. But „freehand‟ objects usually have a lot of nodes making shape 

corrections tedious and unpractical. Usually, it is much faster to delete such a 

shape and draw a new one than trying to edit the original shape. To make the 

process easier, you can start to draw a new shape with the <Alt> key pressed. 

This automatically removes the current shape and the new shape replaces the 

previous one. 

Pressing and holding the pencil tool button, reveals the additional tool menu 

with the Smooth and Autoshape items.   
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With the smooth mode selected pencil created objects will be automatically 

converted „on the fly‟ to Bezier shapes - limiting the number of nodes and 

making future corrections of the object a lot easier. With the autoshape mode 

switched on, the tool tries to guess which sort of closed shape you were 

drawing. When closed shape drawing is finished, the autoshape turns the shape 

into circle, ellipse or rectangle – whatever fits the original shape best. 

The pencil created path/region object can display several measurement values: 

horizontal width, vertical height, length (path only), perimeter (region only) 

and area (region only). 

Ellipse and rectangle tools   

The ellipse and rectangle tools are used to create ellipse and rectangle objects. 

During drawing a new object is always aligned horizontally or vertically. Once 

created, it can be rotated with the pointer tool. 

When the object is created with the <Alt> key pressed, it is drawn as circle or 

rectangle respectively. 

Ellipse and rectangle objects can display several measurement values: width, 

height, perimeter, area and angle. 

 

 

The autocreate tool   

See the Chapter 8 for details. 

The distance (dimension) tool   

The distance tool is used to draw dimension vectors. Dimension vector is 

displayed as a line with arrow-shaped caps. Dimension vector can display 

several measurement values: width, height, length, and angle. 



 

 

 

   

User Manual Micrographica Standard & Video Edition v 1.7.0 Page 28 

 

The arrow and label tools   

The tools are used to create arrows and texts on an image. Texts can be 

created and edited „in place‟. To finish text edit press the <Enter> key. Press 

the <Esc> key to cancel the text edit. „In place‟ edit allows you to create 

single line texts only. Full control over the text is possible in the label 

properties dialog, which opens after double-clicking on the object. The dialog 

can also be accessed via the <Properties> item in the context menu. In the 

dialog you can set font properties and edit multiline text. 

The arrow and label are actually two styles of the one object type. The object 

can be presented as arrow only (arrow), text only (label) or arrow and text. 

The properties dialog allows you to choose the display style. This object type 

does not provide any measurement value to display. It is a pure annotation 

object. 
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The counter tool   

The counter tool allows you to count unlimited separate sets of objects. By 

clicking with the tool on an image you can add or remove elements of the 

current counter. The element of the counter displays an arrow combined with a 

text in form of „C #N‟ where C – is the counter number and N – is a subsequent 

number of the element in the counter. 

When any element of the counter is the current object, subsequent clicks will 

add next elements to the counter. When the current object is not a counter 

element (i.e. ellipse, arrow, etc.) or there is no current object selected, the 

first mouse click creates new counter together with its first element. You can 

easily switch from counting with one counter to another by selecting (with the 

pointer tool) any element of the other counter. Then, the element (and its 

counter) becomes current, and next elements will be added to that counter. 

 

Counter‟s elements can be individually moved and deleted. When any element 

is deleted, numbers are adjusted automatically, so there is never any gap in 

numbering. 
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Measurement table and statistics 

The measurement table is a docking window, which can (as other docking 

windows) be accessed via menu View->Windows->Measurements. 

 

 

The measurement table consists of two sub-tables. The lower one is the actual 

measurement table. It lists all the measurement objects with all the values 

they deliver. 

The upper sub-table offers various statistics. The tabs represent all available 

measurement object types i.e. dimensions, ellipses, rectangles, regions etc. By 

selecting a tab you can see statistics data about all objects of the selected 

type.  
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Table columns can be rearranged by dragging a column title with a mouse and 

Ctrl key pressed. 

By clicking the <Export data to a spreadsheet> button data can be exported in 

the text format suitable to open in any spreadsheet application as MS Excel. 

Tips... 

During the annotation and measurement process you may be switching 

frequently between the pointer tool and other tools on the annotation toolbars.  

To make this switching easier you can use the following shortcuts: 

When any other tool is active, pressing and holding the <Ctrl> key on the 

keyboard temporary activates the pointer tool. Releasing the key returns you to 

the previous tool. 

The same is possible with the zoom tool. In this case pressing and holding the 

<Space> key on the keyboard temporarily activates the tool. 
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Chapter 7  - Still image 

processing 

This chapter describes how to perform image 

processing on still images. 
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In brief... 

 Use menu View->Windows->Image Processing to display the image 

processing window. 

 

 Click right-mouse button on the window to display the context menu. 

 Use Filter append-> to add a new image processing filter and put it at the 

end of filter chain. 

 

Click right-mouse button on the window to display the context menu. 
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 Use Filter insert above-> or Filter insert below-> to add a new image 

processing filter and put it above or below the current filter. 

 Switch Preview to [On] or [Overlay] to see image processing result on the 

workspace. 

In detail... 

In order to perform measurement and analysis tasks on digital images some 

alteration of the image is often required. This alteration is called image 

processing and is carried out to make an image more readable and defined. 

Image processing typically enhance some details (features) of an image in 

expense of other features. For example, it may make some objects in the 

image bigger and other objects smaller or disappear. Or may make foreground 

objects more visible and background objects less visible etc. 

The image processing is usually done by applying so-called filters to the input 

image. An image processing filter is an operation, which takes all pixels of the 

input (source) image and transforms them into modified pixels of the output 

(destination) image. 

Some image processing tasks can be done by applying only one single filter to 

the input image. Other, more complex tasks require several filters to be 

applied, one after the other. In that situation the first filter transforms the 

source image. This result is then transformed by the next filter and its result 

goes onto the next filter etc. 

Image processing tasks fall into certain categories. These are colour correction, 

convolution, deconvolution, segmentation and others. 

For image analysis and measurements, segmentation is perhaps the most 

important image processing task. Its aim is to transform an input image (full 

colour or greyscale) to purely two colour (black and white) image - a so-called 

binary image. When segmentation is done correctly the interesting features in 

the image (objects) become white and the rest (background) is turned black. 

The benefit of binary images is that it becomes much easier to distinguish the 

features from the background and measure or analyse them. 

Micrographica offers a wide range of image filters. Click right-mouse button on 

the Image Processing window to start adding or removing filters to the current 

filter set. 

Filters in the set are applied to the image one by one, starting from the 

topmost filter. The result of the last (bottom) filter of the set is displayed in 

the workspace, when the box [On] is checked in the Preview section. When 

any parameter value of any filter in the set changes, all filters are applied 

again to the original image, so the preview in the workspace always reflects the 

current settings of the filters. 
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Set of filters applied to the source image. 

 

When the preview is in overlay mode ([Overlay] button is on), the result of the 

image processing is displayed as a colour layer on top of the original image. The 

layer is more transparent, where the result is darker and less transparent, 

where the result is lighter. This mode is most useful when the image processing 

result is a binary image. Then, white areas (objects) will be opaque and black 

areas (background) will be transparent in the overlay on top of the original 

image. By default, overlay colour is red, but it can be changed with the colour 

selector button on the right side of the window. 

The small grey box in the top right corner of the Preview section is an indicator 

of filter activity. It changes its colour to orange when any filter in the current 

set is working i.e. processing the image. The filters work in the background 

process, so this activity does not block the user interface. But it takes some 

time for the filters to process the whole image and display the result. When an 

image is big, or there are a lot of filters in the current set, it may take a while 

before you see the changes in the preview. The indicator shows that busy state, 

which means: „what you see is not yet the result‟. 

In the section Preset you can save the current filter set. All saved presets are 

visible on the preset list. When a new preset is selected, the filter set of the 

preset replaces the current filter set, the filters apply to the image and the 

preview is updated. 
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Image processing filters 

The following sections describe all image filters installed by default with the 

current version of Micrographica. As filters are plug-ins to the application. New 

filters can be added with future releases by Micrographica software team or by 

third party developers. 

 

No filter in the set – the preview is identical with the original image. 

Colour Correction 

This filter can be used to change brightness, contrast and colour of an image.  

The top slider affects the image‟s gamma i.e. its brightness and contrast. 

The <Auto contrast> button automatically sets the optimum contrast for the 

image. When the image already has the optimum contrast, clicking the button 

has no effect. 

The middle slider changes the image‟s saturation. Click the <Auto saturation> 

button to automatically set the optimum saturation for the image. When the 

image already has the optimum saturation, this button has no effect. 

The bottom slider is used to change overall hue for the image. When the slider 

stays in the middle position (where the background colour of the slider is 

white), no hue change is made. When the slider is moved left or right - closer 

to any of the two bounding colours - it moves the image‟s overall hue towards 

that colour. By pressing and dragging the mouse up or down in the colour box 

on the right side of the slider, you can adjust bounding colours of the slider. 

To automatically determine the white balance of the image, click the <Auto 

white balance> button. Then, the slider is set on the position which shows the 

colour of the lightest pixel in the image. When that colour is not neutral (white 

or grey), the image might be out of the white balance i.e. may have a colour 

shift. By moving the slider to the centre, the correct white balance can be 

achieved. 
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Colour correction applied. The image is made darker, more 
saturated and all colours are shifted toward the magenta hue. 

Channel Separation 

This filter is used to turn a multi channel (colour) image into a one-channel 

(greyscale) image. There are six channels which can be extracted from a colour 

image: lightness channel (L), saturation channel (S), hue channel (H), red 

channel (R), green channel (G) and blue channel (B). Extracted channel can be 

additionally inverted (made negative) by checking the [Invert] box. 

The channel separation filter is typically used as a first step before any 

segmentation (e.g. threshold) filter is applied. 

 

Channel separation applied. The saturation (S) channel is 
extracted and inverted. 
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Blur + Enhance 

This filter blurs and/or enhances the details in an image. The slider sets the 

blur amount. When the [Enhance] box is checked, edges of objects in the 

image become wider and lighter. 

The filter is often applied after a threshold filter. A threshold usually creates 

jiggered edges on an image. Blurring makes them smoother and improves their 

shape.  

 

 Blur and enhance filter applied. 

Color threshold 

The filter finds a colour range in the image, and replaces it with another 

chosen colour. The input range can be selected in three colour modes: 

grayscale mode, RGB mode and HSL mode. You can chose a mode using the 

buttons on top of the dialog. 

In any mode you select the colour input range using sliders. Every pixel, whose 

colour falls into the selected range, is replaced by a pixel with the destination 

colour, which can be set by the [Dest. Color] button. 

In grayscale mode, you select only lightness range. This means that image 

pixels will be selected by their lightness only, regardless of colour. 

In RGB mode, input colour range is selected by using three sliders. Each of 

them defines a range of red, green or blue component. 

In HSL mode, input colour range is also selected by using three sliders. The top 

slider sets a range of lightness to select, the middle slider sets the saturation 

range and the bottom slider sets the hue range.  

The input colour range can also be set by using the <Source color> eyedropper 

tool. When the tool is selected, you can press and drag the mouse cursor on the 

image. Each colour under the moving cursor is then added to a new source 

colour range, until the mouse button is released, which also switches the tool 

off and confirms the colour range. The destination colour can also be set by 
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using the <Dest. color> eyedropper tool. The destination colour is then 

selected by a single mouse click on the image. 

The remaining unselected area of the image can be replaced by a single colour 

as well. It is done by checking the <Background color> box and setting a 

background colour. 

 

The source colour range selected (blue background) and replaced 
 with black. 

By default, destination colour is white, background colour is black and the 

input mode is grayscale. With those settings, the filter behaves as a simple 

threshold filter and creates black/white binary image. 

 

The same picture processed with default settings. Grayscale mode is selected  
and black/white used as destination and background colours. The result is binary  
image as one would get with a simple threshold filter. 
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[Auto thresh.] box is used to automatically determine input colour range. This 

is particularly useful when an image contains limited number of colours/shades. 

Automatic threshold is then able to quickly separate objects from background. 

The selected (and filled with a destination colour) area can be blurred and 

opened or closed. Those can smooth edges of the area and remove any 

„garbage‟. 

Adaptive Threshold 

The adaptive threshold filter turns each pixel black or white, depending on  

a difference between the pixel‟s lightness and the average lightness of its 

vicinity. If the difference is big enough, the pixel and its vicinity are turned 

into white. Otherwise, they are turned into black. 

Adaptive threshold is a common method for image segmentation. It detects 

higher local differences in lightness (usually objects) and makes those areas 

white. Areas with smooth changes in lightness (usually the background) become 

black. 

The adaptive threshold filter works only on greyscale images. When the input 

image is a colour image, the channel separation filter should be used first. 

Otherwise, the adaptive threshold filter has no effect. 

 

The adaptive threshold applied. Min. value is set to lowest, so 
even small shade differences are detected and those areas are 
changed to white. 

Object separation 

It is a very important segmentation filter. Its aim is to find closed, connected 

areas in the input image and split them into separate objects surrounded by 

contours. 

It works best when applied to binary images, where areas you want to separate 

into features (objects) are white, and the rest (background) is black. As the 

result you get separated, white regions on the black background.  
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Original image Binary (threshold) image Separated objects (filled mode) 

 

During the process the filter decides which white areas should remain 

unchanged and which ones should be separated. The decision is based on the 

shape of an area. If the shape is convex – i.e. doesn‟t have prominent „defects‟, 

it is guessed that the shape represents a single object. Otherwise, the shape 

may be the composition of several overlapping objects and will be split into 

separate areas. 

The filter has two modes of operation. When you check the [Filled] box you get 

your separated areas filled with white. With the [Borders only] box checked, 

you get your areas filled with black, but their borders will be white. With the 

[Details] slider you can adjust the level of separation. With higher settings the 

filter tries to divide shapes more aggressively, but too big value may cause 

some shapes to disappear. 

 

Borders only mode, details are set to minimum. The processed preview displayed as overlay. 



 

 

 

   

User Manual Micrographica Standard & Video Edition v 1.7.0 Page 42 

 

The same image with details level increased.  

 

The filter ability to split compound, overlapping areas into separate regions, 

makes it a common tool when automatic object counting is required. 

Opening and Closing 

The Open/Close filter is a typical morphology filter. When „opening‟ is applied, 

small light areas in the image join together, while small dark areas disappear. 

When „closing‟ is applied, the opposite happens. 

The filter is typically used to get rid of small light or dark „garbage‟ without 

much affecting larger areas. 

Although the filter can be applied to colour or greyscale images, it is mainly 

used to improve binary (segmented) images. 

 

The open/close filter is applied on binary image. Neutral value 
is set on the slider; therefore no effect is yet visible. 
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 The closing applied.     The opening applied. 

Dilation and Erosion 

The Dilation/Erosion filter is another example of a morphology filter. When an 

image is dilated, light areas enlarge, while dark areas contract. With eroding, 

the opposite happens. 

The filter is typically used to enhance light or dark areas. 

Although the filter can be applied to colour or greyscale images, it is mainly 

used to improve binary (segmented) images. 

       

 The erosion applied.     The dilation applied. 

Deconvolution 

The deconvolution process is used to improve details in the image. The 

deconvolution filter tries to reverse an inevitable degradation of the image 

quality, introduced by the optical path (microscope lenses, camera sensor etc.) 

used to capture the image. 

Two deconvolution methods are available: The Fast Fourier Transform 

algorithm and the Lucy-Richardson algorithm. 
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The deconvolution filter applied using Lucy-Richardson method. 

Tips... 

Filters can be added to the current set by using the drag and drop method. All 

available filters are listed in the Image Filters window. An icon dragged from 

the window and dropped onto the Image Processing window will insert the 

filter into the current set. A filter can also be dropped onto the workspace 

directly. This will also append the filter to the current set. 
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Chapter 8  - Automatic feature 

detection and object creation 

This chapter describes how to create annotation 

and measurement object automatically, based 

on detected image features. 
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In brief... 

 Click on <Auto create tool> and select the object type to create. 

 Press and drag on the selected image feature with the mouse cursor to 

automatically create the desired object. 

In detail... 

Manual drawing of annotation and measurement objects can often be tedious 

and time consuming. The automatic object creation tool can significantly 

improve the process.  

By pressing and holding the <Auto create tool>, the tool menu opens and 

allows you to select the type of object for automatic creation. The creation 

process must be based on a certain feature visible in the image. The feature 

should be as much defined as possible i.e. distinct from its background or 

vicinity. To create an object of the selected type, press with the mouse on the 

feature (preferably close to its centre) and drag the mouse cursor towards an 

edge of the feature. The feature is detected and the annotation or 

measurement object of the selected type will be automatically created (with 

the right position/shape) after releasing the mouse button. 

Feature detection is based on a colour similarity between adjacent pixels. By 

dragging the mouse cursor on the feature, one actually defines a colour range, 

which will be taken into account during detection. 

Due to the nature of the detection process, better results will be obtained 

when searched features have well defined and narrow colour range. It means 

that some image processing should be used to get better detection results and 

the automatic creation should then be performed on the preview (processed) 

image. When the image is binary (image segmentation has been applied) the 

detection is easiest, as there are only white features on the black background 

(or opposite). In that case dragging is not necessary, and only a single mouse 

click on a feature is sufficient to detect it. 

On a binary image you can even detect several features and create objects for 

them at once. To do so, check the [Group] option in the tool menu. Then mark 

a rectangular area on the preview image with the mouse cursor. All the 

features within the rectangle‟s boundary will be detected and for each of them 

the object will be created. Remember, the group mode works properly only on 

binary images. 
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Tips... 

Effectiveness and accuracy of the tool largely depend on the image processing 

filters used and a proper marking of a feature. Sometimes, the object created 

on a base of detected feature does not look exactly as expected. Instead of 

deleting the object and creating it from scratch, you can attempt to create the 

object again, with the <Alt> key pressed. The newly created object will then 

replace the current one. 
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Chapter 9  - Using masks and views 

This chapter describes how to create mask and view 

objects. 
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In brief... 

 To create a mask on the image, click <Mask tool> on the annotation toolbar 

and draw a region in the workspace by dragging the mouse cursor. 

 To create a view on the image, click <View tool> on the annotation toolbar 

and draw a rectangle in the workspace by dragging the mouse cursor. 

In detail… 

Masks 

Masks are neither measurement nor annotation objects. They are used to „hide‟ 

some parts of the image, before any image processing is applied. This can be 

useful when the image contains both important and less important features, 

which cannot be distinguished by using any image processing. 

A mask is drawn as a freehand, closed contour in a similar way the pencil tool 

works – see Chapter 6  -. When the image processing preview is off, existing 

masks are presented as editable polygon objects filled semi-transparently with 

a colour. All masks share the same colour - so the colour selected for any mask 

is applied to all masks. 

Masks visible on the original image when neither preview 
nor overlay mode is turned on. 

 

When image processing preview is switched on, you can see all masks applied 

to the image. On the preview they are not selectable or editable objects 

anymore, and are filled with the solid colour. Masks are rendered on the 

preview image as the first image processing step - even when no filters are 

applied. If image processing filters are used, they are applied after masking. 
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Masks can be switched on and off by using the [Show masks] button on the 

sidebar of the workspace. 

You can invert masks by using the [Invert masks] button on the sidebar of the 

workspace. 

Masks, like other objects can be moved, modified, hidden or deleted at any 

time, providing that neither preview nor overlay mode is active. 

 

 

Normal masks applied on the preview. 

 

 

Inverted masks applied on the preview. 
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Views 

Like masks, views are neither measurement nor annotation objects. They are 

rectangular areas you can place on the workspace. When any view is activated 

or by a double click, or by the option ‘Set as the current view’ in its context 

menu (right mouse button click), the visible area of the image becomes limited 

to the area of the active view. Effectively, the image is cropped by the view, 

but you can always switch off the view and return to the default full view. 

To return to the full view click the [Reset to the default view] button. The 

button is located on the right sidebar of the workspace. 

Views - like other objects - can be moved, modified, hidden or deleted from 

the workspace at any time.  

 

         

The inactive view in the workspace.  

 

The workspace with the activated view. 

Tips... 

Views are useful when a complex image processing is required on a big image. 

In this case, any change or adjustment made for image filters requires a whole 

image to be processed by all filters, in order to calculate and display the 
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preview. This process takes time and makes adjustments much less interactive. 

With a smaller view activated, you can achieve the desired result faster, as 

only part of the image (the view) requires processing. When you are satisfied 

with your image processing parameters, you can return to the full view and 

wait for the final result to be calculated for a whole image. 
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Chapter 10  - Saving and loading 

still images 

This chapter describes how to open, save and 

export still images from/to disk. 
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In brief... 

 Use menu File->Load Image… to display file load dialog. Optionally click 

<Load image> icon on the File tools toolbar. 

 

 

 In the dialog select the image file to open. 

 Use menu File->Save Image… or File->Export Image… to display file save 

dialog. Optionally click <Save image> icon on the File tools toolbar. 

 In the dialog select image file name to save the current image on disk. 

In detail… 

Micrographica works on the single document interface basis. This means that 

only one document (image or video) can be open at the same time. This may be 

considered as a limitation, but it helps you to concentrate on the task and 

prevents you from being confused with many open images, one obscuring the 

other. When the current image has been modified - by adding or editing 

annotation objects or filters - it should be saved before any other image can be 

opened, created or captured within the same session. Otherwise, the warning 

dialog is presented asking you to save the current image. 

There are two methods for storing modified images: save and export. The save 

operation stores the image under a selected name – so it always behaves like 

„Save as‟ operation. The saved image remains untouched i.e. no pixels are 

modified compared to the original opened or captured image. All calibrations, 

objects and image processing filters used are stored as metadata information in 

the image file. This means, when the file opens in Micrographica again, all the 

objects, calibrations and filters remain in the same state as they were when 

the file was saved. They also will be still editable, so you can continue or 

modify your work. When such image file is opened in any other application, the 

metadata will have no meaning and you will see a „clean‟ unchanged image. 
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To store a file with all objects „welded‟ into the image and all the filters 

applied, export the image instead of save. In that process, the original image 

pixels are modified by applying all image filters and drawing all objects. The 

exported image will be shown by other applications in the same way as in 

Micrographica. The objects and image processing filters will not be editable 

anymore. 

Save and export use the same selection of image file formats – .jp2 (JPEG2000), 

.jpg (JPEG), .tif (TIFF), .png (PNG), .mng (MNG), .bmp (BMP). There can be 

additional formats available to open (e.g. NIS .nd2). 

Tips… 

When you select a compressed format for saving (.jpg or .jp2), you must 

remember that those compressions are not lossless. Every save will slightly 

degrade the quality of the input image. For this reason, it is better to save files 

in other formats which keep the original quality unchanged, especially when 

the image is going to be used for further editing or processing.  
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Chapter 11  - Report 

generation 

This chapter describes how to create and 

edit reports. 
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In brief... 

 Use menu Tools->Reports… to display the report creation dialog. 

 

 In the dialog select an option to create a new report from template, open an 

existing report or create a new template.  

 In case of creating a new report or template, select a name for the new 

report or template. 

 Click <OK> to open the report editor. 

 Use the editor to create and save/print the report. 
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In detail… 

Reports are text files, which can be created from within the application to 

document current work or analysis. Reports can also contain pictures taken 

from the current image or inserted from disk files. 

Reports can be created as plain or template based documents. A plain report is 

made from scratch starting with an empty page.  A template based report takes 

an already existing document (the template) and sets it as the initial content of 

the new report. Templates can also contain some special empty fields, which 

are filled with actual data when the report is created. 

Creating a plain report. 

Enter a name for the new report in the Name field. Select the <empty> 

template in the Templates list. Press [OK] to close the dialog and open the 

editor window. 

The editor has all typical features of a simple word processor. You can select 

font, colour, style and alignment of a text. Copy, cut, paste, undo and redo 

operations are available and accessible from the toolbar. The current image (or 

visible frame of the current video) can be inserted into the document by using 

the [Insert current image] button on the toolbar. Other commands like current 

date, file name and image file insertion are available under context menu 

(right-mouse button click). 
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Creating a template based report. 

Enter a name for the new report in the Name field. Select the desired template 

in the Templates list. Press [OK] to close the dialog and open the editor 

window. 

The new document will contain all elements (text and images) inherited from 

the template. If the template contains the special „current image‟ mark, the 

current image will be automatically inserted in the place of the mark. If the 

template contains „#DATE‟ or „#FILE‟ fields, the fields will be replaced by the 

current date and the name of the loaded image or video file respectively. 

Further editing of the report doesn‟t differ from editing a plain report. 

Creating a new template. 

Enter a name for the new template in the Name field. In the Templates list, 

you can select <empty> to start with a clean document, or select a template 

to start with a copy of the selected one. 

A template is created and edited in the same way as any other document. The 

main difference is that special marks and fields can be inserted. When you 

insert the current image (using the button on the toolbar or context menu), a 

grey square is displayed instead. If you insert date or file name, „#DATE‟ and 

„#FILE‟ fields are inserted. Those fields will be replaced by the actual image, 

date and file name, when you create a report based on the template. 

Saving and loading reports. 

Reports are always saved in the special folder located in: 

C:\Documents and Settings\All Users\Application Data\Micrographica 

Software\Micrographica\reports 

The folder has a separate subfolder for each report created. The report‟s 

subfolder contains the document file and the image file, which is a copy of the 

current image. 

The Report creation dialog displays all available reports when the [Load 

existing report] button is checked. By selecting a name from the list and 

pressing [OK] the report can be loaded into the editor. 

Tips… 

Report files are stored in HTML format. It means that a report file can be 

directly used on a web server as a web page, and can be displayed by any web 

browser. 

When a report is copied to a different computer or a web server, the whole 

subfolder should be copied rather than the document file alone. This ensures 

that image files are copied as well, and allows the report to be displayed 

correctly on the new computer. For the same reason, if you want to add other 
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image files to the report, you should copy those files to the report‟s subfolder, 

before inserting them into the document. 

You can use an external editor instead of the embedded Micrographica editor 

to edit reports and templates. The external editor program can be set after 

checking the [Open report in an external editor] box. The selected editor 

must  support HTML format (e.g. MS Word). 
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Chapter 12  - Extended depth of 

focus composition 

This chapter describes how to create an extended 

depth of focus image from a series of images with 

different focus depths. 
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In brief... 

 Use menu Tools->Extended focus… to display the EDF composition dialog. 

 

 Use the <Add> button to display the file open dialog and select the images 

for composition. 

 Use the dialog controls to select composition settings and display 

composition preview. 

 

 Click <OK> to create a final composition and display it in the workspace. 

In detail… 

The extended focus feature is used to combine several images of the same 

scene, made with different focus depth, into one image with extended depth of 

focus (EDF).  

Images selected for EDF composition are displayed as thumbnails on the list. 

Images can be added and removed from the list at any time. Every such change 

on the list causes the composition preview to be rebuilt. The result of the 

composition preview can be seen in the preview area on the top right side of 

the dialog, when the <EDF Preview> box is checked. With the box unchecked, 

the preview area displays the current image selected on the list. 

There are two parameters controlling EDF creation. The Details slider decides 

whether the distinction between sharp (in focus) and soft (out of focus) areas is 

fine or coarse. Fine composition (left slider position) guarantees that small 

details in the images will be preserved, but it more likely produces artefacts 

(„garbage‟) in the final image. Coarse composition (right slider position) gives 
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fewer artefacts, but some details in the images can be lost. Artefacts can be 

reduced by using Smoothness factor in expense of the overall sharpness in the 

final image. 

If images are misaligned (the same objects have slightly different positions on 

different images), the composition process compensates for any shift and 

images are automatically aligned. 

Every change in above parameters results in rebuilding the preview.  

When you are satisfied with the composition, click the [OK] button to close the 

dialog and start the EDF composition in full resolution. When it finishes, the 

result image becomes the current working image and is displayed in the 

workspace. 

 

EDF composition dialog with the preview of current composition. Note, that images are 
misaligned - objects are shifted from left to right on subsequent images, but the final 
composition is correct due to the automatic shift compensation. 

Tips… 

The result of EDF composition depends on the image order on the list. Usually, 

better result can be achieved when the image with in-focus (sharp) background 

is the first one, and the image with the in-focus foreground is the last one. 

Sometimes however, the pictures may be taken in opposite order. Then, you 

can reverse the sorting order on the list with the [Reversed order] button. 
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The image files on the list are always sorted by name. Therefore, it is 

important that the order of focused planes should be consistent with the file 

name order. It means that the in-focus plane should „move‟ gradually from 

background to foreground or from foreground to background on subsequent 

images when they are sorted by name. 
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Chapter 13  - Image stitching 

- Mosaic 

This chapter describes how to create a full size 

image from a series of image tiles. 
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In brief... 

 Use menu Tools->Mosaic… to display the mosaic composition dialog. 

 

 Use the <Add> button to display the file open dialog and select the images 

for composition. 

 Use the dialog controls to select composition settings. 

 Click <Prepare mosaic> to create a composition preview. 

 Click <OK> to close the dialog and display the final composition in the 

workspace. 
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In detail… 

The mosaic feature is used to combine (stitch) several images each being a 

fragment of the same scene into one image containing the full scene. All 

fragment images have to be of the same size i.e. the same width and height in 

pixels.  

Images selected for mosaic composition are displayed as thumbnails on the list. 

Images can be added and removed from the list at any time. Every such change 

on the list requires the composition preview to be rebuilt. The result of the 

composition is created after clicking <Prepare mosaic> and can be seen in the 

preview area on the top right side of the dialog, when the [Mosaic Preview] 

box is checked. With the box unchecked, the preview area displays the current 

image selected on the list. 

Two modes of operation are provided: automatic and pre-ordered: 

When the [Images preordered] box is unchecked, the automatic mode applies. 

The software will try to combine all images on the list into the final image 

based on overlapping areas. To succeed, fragmented images must cover the 

entire final image without any gaps. It also means that every single image must 
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have an overlap with each of its neighbours. The parameter [Overlapping 

margins bigger than] is a hint for the stitching process. It should be set as a 

percentage of each image‟s width and height. Actual overlaps existing on the 

images cannot be smaller than the parameter set, although it can be bigger (up 

to 50%). With automatic mode the images on the list can be randomly ordered. 

 

 

 

When [Images preordered] box is checked, the mosaic process assumes that 

the final image should be created as a grid (with rows and columns) from 

individual fragments (tiles). Therefore, the number of images on the list 

must equal the number of columns multiplied by number of rows. Mosaic 

always tries to place and stitch images from top to bottom row. When [Z-

scan] is selected, each row is composed from the leftmost column to the 

rightmost column. When [S-scan] is selected, the first and each odd row is 

created from left to right, but the second and each even row is created from 

right to left. 

15% 

11% 

25% 

20% 

Example: 

When the parameter [Overlapping margins bigger than] is set to 10%, actual 

overlaps must exceed the size but cannot be bigger than 50% 
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After any change of the parameters, the current composition becomes invalid 

and you have to click on <Prepare mosaic> to create a new preview. 

The composition can be cropped or/and rescaled to a chosen size using [Crop] 

and [Resize] options. 

When you are satisfied with the composition, click the <OK> button to close 

the dialog and start the mosaic composition in full resolution. When it finishes, 

the result image becomes the current working image and is displayed in the 

workspace. 

Tips… 

Image stitching process can fail if the mosaic parameters are improperly set or 

the task is too complex to handle. In that case, the preview area displays a 

warning message explaining possible reasons of the failure. 
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To achieve good results you need to apply some simple rules: 

1. All input images (tiles) must have same width and height and cover the 

final area without any gaps or “holes”. 

2. Each tile has to overlap with all its neighbours. 

3. Overlaps cannot be bigger in width or height than 50% and smaller than 

1% of tile‟s width/height. Bigger overlaps will slow down the stitching 

process. 

4. Make sure that [Overlapping margins bigger than] parameter is set to 

the value which is lower than the smallest overlap between any input 

tiles. 

5. Although mosaic can handle misaligned tiles, the process is much faster 

when each tile is horizontally and vertically aligned with its neighbours. 

6. Automatic stitching is much slower. Always prefer using tiles ordered in 

a grid (Z- or S- scan). 

 

Always try to keep the stitching pattern as simple as you can. If you have many 

tiles, randomly ordered, misaligned and with big overlaps – the mosaic may 

require a long time to create a final image or most likely it will fail. 

The result of grid composition depends on the image order on the list. By 

default, the mosaic assumes that the order of rows is from top to bottom. 

Sometimes however, the pictures may be taken in the opposite order. Then, 

you can reverse the sorting order on the list with the <Reversed order> 

button. 
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Chapter 14  - Histogram 

This chapter describes how to show  

a histogram for the current image. 
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In brief... 

 Use menu View->Windows->Histogram to display histogram window. 

In detail… 

 

The histogram is a graph, which shows lightness distribution among image 

pixels. Micrographica‟s histogram shows three graphs for three colour channels: 

red, green and blue. When the image is a greyscale image, all three channels 

are identical and the histogram shows the blue one. 
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The graph presents the number of image‟s (channel‟s) pixels which have the 

same lightness. The leftmost side of the graph represents no lightness (black), 

and the rightmost side of the graph represents full lightness (the brightest 

colour).  

On the picture above you can see that the image has a significant amount of 

pixels with very dark (nearly black) blue, slightly less pixels with dark red and 

barely any dark green pixels. This means that dark areas in the image have 

magenta (blue + red) tint. 

When you go towards the right side of the graph, you see that in the light areas 

there are plenty of green and blue pixels and a few red pixels. On the image 

you can notice that lighter areas (background) are in fact cyan (blue + green). 

The histogram shows pixel distribution of the actual visible image. This means 

that when the preview is off, you see the histogram of the original image. 

When the preview is on, the graph shows the histogram of the visible preview. 

The window can also show a „live‟ histogram of a video material. When a video 

is played from a file or captured from a camera, the histogram changes 

according to the current video frame. 

Tips… 

Live histogram is not always needed but its updating takes some amount of 

processing power. With the video capture or video play, switching off the 

histogram window improves the overall performance. 
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Chapter 15  - Video 

acquisition 

This chapter describes how to work with 

video cameras in order to acquire a new 

video sequence into the program. 

This feature is only available in the 

Video Edition. If you would like to 

upgrade from Standard Edition to 

Video Edition please contact your 

distributor. 
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In brief... 

 Use menu View->Windows->Camera Control to show camera control 

window if it is not yet visible. 

 

 Select the connected video camera device from Select Device list. 

 Manipulate camera settings using controls in the camera control window. 

 Select capture file name from the file dialog after clicking the <…> button. 

 Select the desired video compression from the Compression list. 

 Check [AVI Capture] box. 

 Click the <Play> icon and observe the live view from the camera in the 

workspace. 

 Click the <Record> icon to capture a video sequence. The capture preview 

is displayed in the workspace. 

 Click <Play> or <Record> icon again to stop the capture process and load 

captured sequence into the program. 

In detail... 

To find out basics about using still image and video devices see Chapter 4  - 

Still Image Acquisition. 

Please note, that a still (photo) camera directly controlled by Micrographica 

cannot be used for video acquisition - even if the camera has a video recording 

feature. Of course, the video signal taken from the camera‟s video-out 
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connector can be recorded via a grabber device (USB adapter, PCI card etc.). 

But in this case, the device which Micrographica controls is the grabber itself, 

not the camera. For the software, the grabber is the source of the video signal 

and Micrographica doesn‟t care what device actually produces the original 

image. 

Working with video devices. 

If the connected video device (video camera or video input card/adapter) is 

set-up in the system and the correct controller is installed with Micrographica, 

the device will be visible on the list. Selecting the device from the list 

activates it, but the video preview is not yet visible. Clicking the <Play> button 

starts the live preview, which is displayed in the workspace. Live preview can 

be paused by clicking the <Pause> button. 

For video recording, the video file destination and video compression should be 

set at first. During recording, Micrographica always writes video material to an 

AVI file. The Capture file field determines the file name and its folder. The 

field cannot be edited manually. Click the <…> button to display the file save 

dialog and select the destination file. When a new file is selected, it will be 

created during recording. If the existing file is selected it will be overwritten. 

Optionally, the video compression type can be selected from the Compression 

list. The list contains all available video compressors in the system. 

When the video file and the compression are selected, check the [AVI capture] 

box. This will prepare the software to write the video file during acquisition. 

Clicking the <Play> button will start the live record preview, but no recording 

is yet being made. Live record preview can have different image quality or 

frame rate from the „normal‟ live preview. 

Recording starts by clicking the <Record> button. The „lamp‟ on the button 

changes its colour from dark red to bright red. The record preview from the 

device is visible during the recording process. The <Pause> button can have 

different effect with different devices. For some devices it may actually pause 

the recording, but for others it continues recording of a „frozen‟ image.  

The recording process can be stopped by clicking again (untoggle) the <Play> or 

<Record> button. The newly recorded video material is instantly opened in the 

application from the video file created. The workspace displays the first frame 

of the video sequence. 

The use of Set input, Set filter and Set output boxes is described in Chapter 4  

-  

Tips... 

Please note, that only some of available video compressors may suit the 

material delivered by a video device. For smaller video resolutions (less or 

equal to 800x600) most flexible will be the DV Video Encoder or MJPEG 
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Compressor and they should be available by default in most MS Windows 

systems. On the other hand, they offer rather low compression ratio. 

For bigger resolutions (above 800x600, HD and more) older Microsoft MPEG-4 

compressors can be used.  These are not available by default, but can be found 

and installed from the web. Though deprecated, they are still a good 

alternative for commercial encoders. However, consider buying a good quality 

HD video encoder, especially when larger resolutions and long video sequences 

are going to be recorded regularly. 
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Chapter 16  - Animation of 

annotation and measurement 

object on video sequences 

This chapter describes how to animate 

annotation and measurement objects on 

video material. 

This feature is only available in the Video 

Edition. If you would like to upgrade from 

Standard Edition to Video Edition please 

contact your distributor. 
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In brief... 

 Annotation and measurement objects can be created the same way as 

described in Chapter 6  - - Annotations and measurements on still images. 

 Click on the selected object using the right-mouse button to display a 

context menu. 

 From the context menu select Animations->On. 

 Set different object‟s position, shape or other parameters on different video 

frames. 

In detail… 

The primary difference between annotation objects on still images and objects 

in video sequences is the objects in the video can be animated. Annotation and 

measurement objects are intended to mark and measure features on images. 

But on video sequences, those features can change – move, morph, appear or 

disappear, so the objects should also change along with the features they 

belong to. Animated object is an object, whose properties like position or 

shape can be different on different frames of the video material. 

Any object type (except counters) can be animated. Initially, an object is not 

animated and looks the same on any frame of the video. The animation for the 

object can be switched on in the object‟s context menu. Since then, any 

change made for the object on any frame is remembered for that frame. 

For example, on the first video frame set the object‟s position (move it) to the 

top left corner of the image, and on the last video frame set the position to the 

right bottom corner of the image. When the video plays, the object will 

smoothly move from the top left corner of the image to the right bottom one. 

You can set other object‟s positions on other frames, making the animated 

motion more complex. 

A frame where the certain position of the animated object is set is called a 

key-frame. Between key-frames positions are linearly interpolated. 

The position of an animated object is presented as an animation path. It is 

displayed as dashed poly line and shows a path the object is moving on. Nodes 

of the path represent key-frames. The nodes can be moved on the workspace 

by using the pointer tool, which allows you to change the animation without 

need of setting the current frame and moving the object itself. A key-frame 

can be removed by selecting it with the pointer tool and pressing the <Del> key 

on the keyboard. The animation path can be hidden for an object by the option 

Animations->Hide in the object‟s context menu. When object‟s animation is 

switched on, other object‟s parameters like shape, angle and colour can be 

animated as well. 
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All animations can be reset to the initial state (i.e. all key-frames for each 

animation are removed) by selecting the option Animations->Clear from the 

context menu. Animations can also be switched off at any time by unselecting 

the option Animations->On. 

 

 Ellipse object animated. The animation path is visible. 

 

The animation of an object‟s position can be copied to another object. This can 

be done by using the option Animations->Copy on the source object, and the 

option Animations->Paste on the destination object. Hereafter both objects 

share the same animation and move together. 

For angle and dimension objects animations can be pasted separately on the 

object‟s vertexes. To do so open the destination object‟s context menu by 

right-mouse clicking on the selected vertex (arrow) and then select the Paste 

option. This can be very useful - for example you can copy the position‟s 

animation from one object (A) and paste it into one end of a dimension object. 

Then copy the position‟s animation from another object (B) and paste it into 

second end of the dimension object. Now the one end of the dimension will 

follow the object A, while the second end will follow the object B. The 

dimension object can show length value, which allows you to measure the „live‟ 

actual distance between two moving features in the image marked by A and B.  

The same is possible with the angle object, where separate animations of 

positions can be pasted into the angle‟s arms. The object will then dynamically 

measure the angle between two features in the image. 
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Animated measurement values and statistics are updated live in the 

measurement table, which allows you to make dynamic analysis on video 

sequences. 

Animations on particular object types. 

Angle – Angle position is the actual position of the angle‟s vertex. The arms can 

be animated independently from the vertex. A pasted animation can be applied 

to the whole object‟s position or to any of the arms. 

Path and region – The position of a path is the position of its first node. The 

position of a closed region is the position of its centre. Each node can be 

animated separately, which effectively also animates the shape of a region or a 

path. To animate the shape smoothly between key-frames, the path (region) 

must have the same number of nodes on those key-frames. If the number of 

nodes changes between two key-frames, the shape is not animated on its way 

between those key-frames, but „jumps‟ to the new shape, when the object 

reaches the second key-frame. A pasted animation applies to the whole 

object‟s position. 

Mask – Can be animated in the same way as a region (see above). 

Ellipse and rectangle – The object‟s position is always its centre. The shape 

(width and height) and angle of the object can be animated independently. A 

pasted animation applies to the whole object‟s position. 

Dimension – The position is the middle point of the vector. Ends of a dimension 

vector can be animated separately. A pasted animation can be applied to the 

whole object‟s position or to one of the ends. 

Counter – Cannot be animated. 

Label and arrow – The object‟s position is the position of the arrow‟s head. 

The arrow‟s tail (it is also the position of the text label) can be animated 

separately. The text and its style can also be animated. A pasted animation is 

applied to the whole object‟s position. 

View – The object‟s position is always its centre. Width and height of the view 

can be animated independently. A pasted animation applies to the whole 

object‟s position. 

Animation of views can be a very effective tool. For instance, you can animate 

the view object to follow a moving region (feature) in the video sequence. If 

the view is activated, the workspace always displays the same rectangular area 

around the feature, regardless of its current position. When the video is 

playing, you effectively see the still, anchored object on a moving background. 

For example, this can allow you to compensate for some random shifts in the 

video and stabilize the image in order to make measurements or analysis. 
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Tips… 

When measurement objects are animated, measured values can vary from 

frame to frame. The displayed parameter for the object is updated and shows 

its actual value. The measurement table constantly displays all updated values 

for all objects. This involves recalculation on all objects on each frame and 

slows down the display when you are switching frames manually. The update is 

done only when the table is visible, so hiding the table (by closing the table 

window) improves the performance. 

During video play the values (either displayed by objects or by the table) are 

not updated until the video stops. Therefore, video is not slowed down even 

when the measurement table is visible. 
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Chapter 17  - Video processing 

and animation of image 

processing filters on video 

sequences  

This chapter describes how to perform image 

processing on video sequences. 

This feature is only available in the Video 

Edition. If you would like to upgrade from 

Standard Edition to Video Edition please 

contact your distributor. 
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In brief... 

 Create and use image filters the same way as described in Chapter 7  - Still 

image processing. 

 In order to animate specific image processing filter check the box [On] in 

the filter‟s Animation section. 

 Use different settings for the filter on different frames of the video 

sequence. 

 Switch preview to [On] or [Overlay] to see the image processing result on 

the workspace. 

 Click the <Reset> button to remove applied animation from the filter. 

In detail… 

When image processing is used with video sequences, image filters are applied 

automatically to the current frame, when the frame changes. However, during 

playout it is applied only, when the preview is on, which can slow down the 

visible frame rate. With the preview off, filters are applied to the current 

frame only when the playout stops. This preserves original frame rate during 

video play. The overlay mode doesn‟t work during video playout and the normal 

preview is displayed instead. 

Usually, the image processing effect set on some frames is adequate for the 

whole video, but sometimes the video has lightness or colour fluctuations, 

which may require different image processing parameters on different parts of 

the video to get the desired result. This can be achieved by animation of some 

parameters in the filters. 

Each filter in the image processing set can be switched to animated mode. This 

is done by checking the <On> box in the Animation section of the filter. 

Hereafter, when you change the filter parameters on any frame, the setting is 

remembered for that frame. If the frame becomes the current frame, the 

parameters are set to those values. Such frames with stored values are called 

key-frames.  

Values of the parameter on any frame between key-frames are linearly 

interpolated. Suppose that you turned on the animation of the blur filter at 

frame no. 10, and set the blur value to 2. The frame no. 10 is now the key-

frame. Then, move to frame number 30 and set the blur value to 10. Frame 30 

also becomes the key-frame. At frame number 10 the blur filter will be applied 

with the value 2, and at frame no. 30 the blur filter will be applied with the 

value 10. When the video goes from frame 10 to 30, the blur value gradually 

changes from 2 to 10. For instance, at frame 20 (exactly in the middle between 

key-frames) blur value will be 6. 
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The animation can be removed from the filter by pressing the [Reset] button in 

the Animation section. This removes all animation key-frames created. 

 

Colour correction filter with the animation 
mode switched on. 
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Chapter 18  - Loading and 

saving video sequences 

This chapter describes how to open, save 

and export video material on disk. 

This feature is only available in the Video 

Edition. If you would like to upgrade 

from Standard Edition to Video Edition 

please contact your distributor. 
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In brief... 

 Use menu File->Load Image… to display the file load dialog. Optionally click 

<Load image> icon on the File tools toolbar. 

 

 

 In the dialog select the video file to open and display the video sequence on 

the workspace. 

 Use menu File->Save Image… to display file save dialog. Optionally click 

<Save image> icon on the File tools toolbar. 

 In the dialog select metadata file name to save the current video sequence 

on disk. 

 Use menu File->Export Image… to display file export dialog.  

 In the dialog select image or video file name to save the current frame or 

video sequence on the disk. 

In detail… 

As with still images, Micrographica can open only one video at the time. This 

means, that when the current video has been modified, it should be saved 

before any other video is opened or captured within the same session. 

Otherwise, the warning dialog is presented asking you to save the current 

video. 

Micrographica can open video material from video files like AVI, MPG or MKV or 

from custom clip metadata files (.ccmt). These are text files containing all 

data needed to restore a previous video session saved by Micrographica. A 

metadata file collects data about all calibrations, objects, filters and 

animations used on the video material. However, metadata files do not have 

any video material in them. Instead, the metadata file stores the link to the 

actual video file. When you want to copy a metadata file to another location 

(directory, disk, computer etc.) you must also copy the linked video file. 
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There are two methods for storing modified video sequences on disk – save and 

export. 

Save operation saves a metadata file only. The current opened video file 

remains untouched.  

Export the video if you want to save a video material with all objects „welded‟ 

into the image and all the filters applied. 

When any image format (.jp2, .jpg, .tif, .png, .mng, .bmp) is selected for the 

destination file, only the current video frame is exported as a single image file. 

When .avi format is selected, a video file will be exported. Before exporting, 

the Video Export dialog opens. 

Video Export dialog. 

By default original settings from the opened video file are preserved, except 

video compression type, which is set as „No compression‟. The compression 

format, frame size and frame rate can be overridden with the dialog.  

You can also decide which frame range will be exported from the original video 

material. If the end frame number is lower than the start frame number, the 

file will be exported as reversed i.e. the result video will play backward 

compared to the original video. 

Tips… 

Please be aware that no video compression format is lossless. This means that 

every time a video file is opened and exported with a compression, the video 

quality degrades. You should always consider using uncompressed video format 

for export, if the video is going to be used for further editing or processing.  
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Micrographica software cannot guarantee that any video file can be successfully 

opened and displayed in the application. Even when the video file can be 

played out with other applications installed on your computer, Micrographica 

may still refuse to display the video content. This is due to the fact that the 

program does not only play the video, but also has to work on individual frames 

extracted from the video stream. Some video decoders („codecs‟), which are 

necessary to play out the video, make that extracting problematic or even 

impossible. As a result, the video material successfully opens in the 

application, but shows no image. This is the case with some MPEG-4 decoder 

implementations, like DivX. Fortunately, this problem applies mainly to those 

compression formats which shouldn‟t been used with laboratory video material. 
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Chapter 19  - Tracking features 

on video sequences 

This chapter describes how to animate 

annotation and measurements objects by 

detecting and tracking features on video 

sequences.  

This feature is only available in the Video 

Edition. If you would like to upgrade from 

Standard Edition to Video Edition please 

contact your distributor. 
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In brief... 

 Use menu Tools->Tracking… to display the tracking window.  

 

 

 

 Select existing annotation object on the workspace. 

 Place and adjust the tracking rectangle on the feature, which you want to 

track. 

 Click <Start Tracking> button to track the feature and create an animation 

path, which will be applied to the object. 

In detail… 

In video sequences structures or features in the image can be in motion. The 

aim of tracking is to detect motion paths of selected features. Detected motion 

paths can be further applied as animations for annotation or measurement 

objects. Since then, those objects - moving exactly like the tracked features in 

the image - can be used to perform dynamic measurements or to prepare 

interesting video presentations. 

To start the tracking, select an existing annotation or measurement object on 

the workspace. The motion path detected during tracking will be applied to the 

object. Two tracking modes are possible, selectable from the Tracking type 

section of the dialog. 
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Position only tracking. 

In this mode, two combined rectangles are displayed, forming so called 

tracking element. The inner rectangle marks the pattern, while the outer 

rectangle marks the search area. The inner rectangle should be placed and 

resized around the feature intended to be tracked along the video sequence. 

The outer rectangle should surround the maximum distance the feature can 

move between subsequent frames. The faster the motion, the bigger search 

area should be marked by the outer rectangle.  

The position tracking is ready to start. The tracking element surrounds the feature (red area). 
The area of the inner rectangle containing the feature will be used as the pattern. The result 
of the tracking will be applied to the selected object (ellipse). 

 

The tracking process goes as follows: The part of the current frame‟s image 

inside the inner rectangle is set as initial searched pattern. The video goes to 

the next frame and every fragment of the new image inside the search area is 

compared against the pattern. When the fragment which matches the pattern 

is found, the algorithm guesses that the tracked feature has moved to the 

position of the fragment. Both rectangles are placed on that position, the video 

goes to the next frame and the process repeats. 

The process finishes when the end of the video sequence is reached, or when 

the difference between the pattern and the best matched image fragment in 

the search area is higher than the tracking tolerance (which can be set in the 

Tracking tolerance box). The 0% tolerance means that only ideal match will be 

accepted. In this case, tracking is likely to break even when the moving feature 

changes only subtly between frames. The 100% tolerance means that any match 
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(even no match) will be accepted, and the tracking will be continued even 

when the moving feature abruptly changes between frames or disappears. 

 

When tracking finishes, the detected motion path is applied to the 

annotation/measurement object as the animation of its position. 

For successful and precise tracking, the tracked feature should be well defined 

and distinctive from the background and neighbours. For that reason, certain 

image processing (usually segmentation) may be needed to achieve good 

results. 

Position and contour tracking. 

In this mode, not only the position of the feature is tracked - but also its shape. 

After selecting the annotation/measurement object, the tracking element is 

displayed. In this case it is a single rectangle, marking the search area only. 

The rectangle should be placed and resized around the feature intended to 

track along the video sequence. The rectangle should also surround the 

maximum distance the feature can move between subsequent frames. The 

faster the motion, the bigger search area should be marked by the rectangle. 

Then, the algorithm tries to detect the closed contour of the feature within the 

rectangle. If such a contour is found, its area is marked by a white, 

crosshatched fill, and the tracking process can be started. The contour is 

treated as the searched pattern. 

Important! The contour can be detected ONLY when image processing is 

applied and the result is a binary (black-white only) image, which means 

the proper segmentation has been achieved. The feature for tracking 

should be a white area on the black background, which can be seen on 

image processing preview. 

When more than one closed contour is detected within the rectangle, the 

biggest one is selected as the pattern. 

The tracking process goes as follows: The initial closed contour is set as the 

pattern. The video goes to the next frame and every closed contour detected 

inside the search area is compared against the pattern. When any contour 

which matches the pattern is found, the algorithm guesses that the tracked 

feature has moved to that contour‟s position and shape. The tracking element 

is placed on that position, the video goes to the next frame and the process 

repeats. 
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The position and contour tracking ready to start. The tracking element surrounds the feature 
(red area). The initial contour of the feature (the pattern) has been detected and is marked 
with crosshatched fill. The result of the tracking will be applied to the selected object 
(ellipse). 

 

The process finishes when the end of the video sequences is reached, or when 

the difference between the pattern and the best matched contour inside the 

search area is higher than the tracking tolerance. The 0% tolerance means that 

only ideal match between contours will be accepted. In this case, tracking is 

likely to break even when the moving feature changes only subtly between 

frames. The 100% tolerance means that any match (even no match) will be 

accepted, and the tracking will be continued even when the moving feature 

abruptly changes its shape between frames or disappears. 

When tracking finishes, the detected motion path is applied to the 

annotation/measurement object as the animation of its position. Detected 

changes of shape are applied to the object as well, providing that the object 

can mark shapes - like region, mask, ellipse or rectangle. 

Tips… 

Some additional parameters can be set to fine tune the tracking process. Those 

are visible when the <Advanced> box is checked. 

When the tracking is in the position only mode, the match between the 

template and an image fragment can be calculated with the one of three 

methods. The default method is Correlation coefficient. The other two - 
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Square difference and Cross correlation can be selected in the <Method> box. 

They are less precise, but can be slightly faster than the default one. 

 

The animation build as the result of the tracking may be dense or coarse, 

depending on number of key-frames created. An animation with the maximum 

density (i.e. a key-frame on every frame) - although it gives the best possible 

representation of the detected motion - is not always needed. When the 

motion is smooth, key-frames may be created less frequently. Such animation 

executes more efficiently and its path is easier to edit and modify. The 

frequency of key-frame creation can be set in the <Create keyframe every> 

box. 

When tracked feature gradually changes along the video sequence, sooner or 

later it will differ significantly from the pattern and the tracking will break. 

Setting the higher tolerance can prevent that, but too much tolerance may lead 

to undesired results like continuing the tracking even when it doesn‟t make 

sense anymore – e.g. when the feature disappeared or „jumped‟ out of the 

search area. In that case (the tracked feature slowly but continuously changes) 

it is better to update the pattern from time to time. It means that on the 

current frame, the found fragment or contour, which matches the pattern best 

(within tolerance) is taken as a new pattern. Such updated pattern will match 

better on next frames and the tracking will continue. The <Update pattern 

every> box allows you to adjust frequency of the update. 

The tracking always starts at the current frame and finishes (if not manually 

stopped before) at the end of the video sequence. The frame range for tracking 

can be limited to some number of next frames with <Track only> and <next> 

boxes. 
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Chapter 20  - Automation of microscopes and 

cameras. 

This chapter describes how to control 

different motorized accessories, which can 

be mounted on a microscope (XY stages, Z 

axis, shutters etc.) and how to integrate this 

control with the connected camera. 

The automation features are available as 

plug-in, which much be purchased 

separately and can be used with both 

Standard Edition and Video Edition. 

Please contact your local distributor for 

more information. 
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In brief... 

 Use menu Tools->Automation… to display the automation window.  

 

 

 

 Select devices to control. 

 Use <Align and calibrate> to calibrate camera image with the selected 

stage device and compensate for any skew of the camera. 

 Use Manual Ctrl and Scan tabs to control motorized accessories. 

In detail... 

The automation module allows you to control different motorized accessories, 

which can be mounted on a microscope (XY stages, Z axis, shutters etc.) and an 

integration of this control with the connected camera. With that integration  

a microscope specimen can be scanned in a number of different ways: 

 In XY plane – creating a single, big image from many smaller individual 

snapshots. 

 In Z axis – creating a single image of extended depth of field (EDF) from 

several snapshots with limited focus depth. 

 By changing the camera exposure time, several snapshots with limited 

dynamic range can be made and then combined into one image with high 

dynamic range (HDR). 

 Any combination of above methods can be used. 

Device selection 

Micrographica can simultaneously control devices from different manufacturers 

as long as the relevant drivers are installed. You have to select which available 

and installed devices you want to control. 

In the <Devices> tab, several categories of accessories are displayed. These 

are: Camera, XY stage, Z axis, shutters and filter wheels. For each category, 

you may select one device from the list. Lists contain only those devices, which 
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are connected to the computer and detected by a corresponding Micrographica 

driver. Usually, there will be only one device available to select from each list, 

but sometimes there can be more than one camera or (less likely) more than 

one XY stage device connected. In that case lists will contain more entries. 

 

 

Camera 

In the automation module, the same rules apply for camera selection and 

configuration, as for standalone camera control (see Chapter 4). 

It is important to notice, that still image photo cameras cannot be used 

with automation. Therefore such a camera will not be visible in the list, 

even if the camera is available as a standalone device in the acquisition 

and camera control dialog. 

Alignment and calibration of the selected camera with a stage. 

In practice, a camera mounted on a microscope is always more or less skewed 

relatively to a stage. In case of non-motorized stages this is usually irrelevant 

or it can be easily corrected manually. 

In case of a motorized stage - when a stage moves along only one axis - even a 

small skew angle causes the image from the camera to move in both axes. This 

undesired effect can be fixed by a careful, manual alignment of the camera, 
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but this is time consuming and an inconvenient method. Instead it is much 

better is to control a stage in a way which associates one axis movement with a 

corresponding second axis movement to compensate for the skew. Then, 

movements observed by a camera will always be parallel to the edges of the 

image. 

Motorized stages give another benefit. They are always calibrated in real 

coordinates (usually microns). It is then possible to calibrate a camera image 

with a specimen without using any micrometer scale bars. To do that, you  

request a stage to move by some real distance and mark that distance on the 

live image. Then, the coefficient between pixels on the image and the 

micrometer distance on the specimen can be obtained. 

Both operations i.e. camera alignment and image calibration can be done semi-

automatically with the Calibration wizard. Start the wizard by pressing the 

[Align and calibrate] button on the [Devices] tab. Using the creator is simple 

by following the instructions displayed on subsequent screens of the window. 

Parameters of the stage alignment are stored together with a corresponding 

calibration in a calibration set. Thus, selecting a different calibration set may 

change the alignment compensation as well. Always make sure that the 

selected calibration set was created for the same camera skew and realign 

using the wizard if needed. 

Manual control of a camera and accessories. 

The tab [Manual Ctrl] gives access to a set of user interface widgets, which 

allow driving the connected devices manually.  
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Manual camera control is limited to switching live preview on/off, pause the 

preview and making a snapshot. The snapshot resolution and all other features 

specific to the camera can be set in the [Devices] tab. 

Several different screen controls can be used to change the stage position in 

three axes. Sliders cause fast movement along axes. Slider position determines 

speed of the move. Wheel thumbnails give precise control of the movement. 

Numeric fields allow you to set the required stage position. 

The program uses a convention in which the user controls a camera view 

over a stationary specimen. Actually, it is the specimen which moves 

together with the stage under a stationary camera. When one requires a 

movement in one direction, the view moves to that direction while the 

stage moves opposite. 

When the live view is on and the box [XYZ Mouse ctrl] is checked, you can 

control a stage by using a mouse alone. Moving the live view on the workspace 

(with Ctrl+Space keys pressed) moves the stage in XY plane. By using a mouse 

wheel the stage is moved in Z axis. Mouse wheel sensitivity can be changed 

with the [Z Sensitivity] slider. Note, that this method is only available when 

the stage has been calibrated with a camera image. 

Current stage position is marked by a small, white cross (on XY plane) and a 

white line (in Z axis) on position preview maps. You can control stage position 

by clicking with a mouse cursor on the map. Then required position is marked 

by a red cross/line and the stage moves in order to achieve the position. 

Individual shutters can be open or closed manually provided that the accessory 

is installed and available. 

Scanning a specimen. 

Scanning is available from the [Scan] tab. You can set XY plane scan, Z axis 

scan and scanning with different exposure times. 

XY scan is controlled with options collected in the [XY and stitching] group. 

Scan is performed in a grid of rows and columns number of which can be set in 

numerical fields. A grid anchor can be set to the top left corner or to the 

centre of the grid. Initially, the anchor position is located in the centre of the 

stage. This can be set to the current stage position by pressing [Start from 

current pos] button. 

Z axis scan is controlled by options in the [Z axis and EDF] group. Slice series 

anchor can be set to the top slice or centre slice. Initially, the anchor position 

is located at the bottom stage position (top camera position). You can set it to 

the current stage position using the [Start from current pos] button. 

Options in the group [Exp. and HDR] are used to set up a high dynamic range 

composition. Selecting the ±1 stop option causes in each XYZ scan point three 

camera snapshots to be taken. One with the current exposure time (stop 0), 

one with doubled exposure time (+1 stop) and one with halved exposure time (-
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1 stop). All three images are then combined into one HDR image. Option ±2 

stop works the same way except that the wider stop range is used (-2, 0 and 

+2) which means that maximum and minimum exposure times are four times 

longer and shorter than the current exposure time. 

When all scan modes are active, for each Z plane three camera snapshots are 

taken and an HDR image is composed. From those images created for all Z 

planes an EDF image is produced. Then the final image is stitched from all EDF 

images prepared in all XY rows and columns. 

 

 

As a result, you produce a high resolution image (mosaic) with extended depth 

of field and high dynamic range. Each scan mode can be switched individually 

so one can create only mosaic image, only EDF or only HDR image as well as any 

combination of those. 

Scan starts after pressing the [Start] button. During scanning process a progress 

bar is visible and the process can be stopped at any time by pressing the [Stop] 

button. With a shutter selected from the list and the box [Use shutter] 

checked, the shutter will be closed during stage movement and open only for 

camera snapshots, preventing a specimen from gaining too much light/heat. 
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Storing and restoring a configuration. 

Setting up a configuration for a particular scan requires several steps i.e. 

selecting a camera and accessories, stage alignment, calibration, choosing scan 

parameters etc. Repeating that process each time, is tedious and often 

unnecessary, e.g. when you want to scan a different specimen in the same 

conditions as a previous one. To make that more convenient the whole 

automation configuration can be stored and later retrieved at a later time. 

The current configuration can be saved by pressing the [Save] button and then 

providing a configuration file name with a default “.aconf” extension. Since 

then, the configuration is available on the list and can be restored at any time. 

The stored configuration also keeps a name and the calibration parameters 

used. When one of the saved configurations is selected, the system tries to set 

the remembered calibration. If the calibration is not available (because it has 

been deleted, renamed or changed in the meantime) the program will recreate 

or restore the calibration after user confirmation. 

If any of the configuration parameters have been modified, the list displays the 

text „Current’, which means that the actual configuration has not been saved 

and will be lost after closing the automation window. 

 

 

 

 


